Народна Освіта » Інформатика » § 16. Математичні та статистичні функції

НАРОДНА ОСВІТА

§ 16. Математичні та статистичні функції

Математичні функції використовують для виконання різних математичних обчислень. З повним переліком математичних функцій можна ознайомитись на вкладці Функції у групі Бібліотека функцій.

математичні функції

Математичні функції в Excel — це функції, призначені для виконання обчислень над числами та / або даними комірок: округлення, перетворення чисел тощо.

Ім'я (англ./рос.)

Опис дії

Кількість аргументів

ROUND(OKPym)

Округлення до вказаної кількості цифр після коми

Два

MOD(OCTAT)

Остача від ділення

Два

PRODUCT(ПPOИЗВEД)

Добуток

Не менше одного

SUM(CyMM)

Сума

Не менше одного

SUMIF(CУMMECЛИ)

Сума за умови, що...

Три

 

Якщо знайти добуток числових даних у діапазоні комірок А1:В2 й округлити його до десятих, то формула матиме вигляд: =ROUND(PRODUCT(A1:B2);1) або =ОКРУГЛ(ПРОИЗВЕД(А1:В2);1)

Статистичні функції

Статистичні функції в Excel — це функції, призначені для аналізу значень діапазонів комірок.

За допомогою статистичних функцій можна знайти найбільше і найменше значення, розрахувати середнє значення тощо.

Визначити, скільки учнів навчаються на 12 балів, можна за допомогою статистичної функції COUNTIF(C4ETE^^. Першим аргументом є діапазон комірок з оцінками, а другим аргументом — критерій вибору:

=COUNTIF(B3:B4;"=12") або =СЧЕТЕСЛИ(В3:В4;"=12")

Знак рівності й лапки в цій логічній умові можна пропустити: =COUNTIF(B3:B4;12) або =СЧЕТЕСЛИ(В3:В4;12)

 

Критерієм вибору може бути не тільки число, але й дата, символ, слово тощо. За критерієм будується умова: чи містить поточна комірка зазначені дані. Наприклад, можна обчислити кількість пропущених учнем уроків (див. рисунок).

Ім'я (англ./рос.)

Опис

Кількість аргументів

МШ(МИН)

Мінімальне значення

Не менше одного

МАХ(МАКС)

Максимальне значення

Не менше одного

AVERAGE(CP3HA4)

Середнє арифметичне

Не менше одного

COUNT(CHET)

Кількість комірок із числовими даними

Не менше одного

C0UNTIF(CHETE™)

Кількість комірок, дані в яких задовольняють певній умові

Не менше одного

COUNTIFS

(CHETE^MH)

Кількість комірок, дані в яких задовольняють декільком умовам

Не менше одного

C0UNTA(C4ET3)

Кількість непорожніх комірок

Не менше одного

Питання для самоперевірки

1. Яке призначення математичних функцій?

2. Наведіть приклади математичних функцій в Excel.

3. Для чого призначені статистичні функції?

4. Наведіть приклади статистичних функцій в Excel.

5. Наведіть приклад застосування однієї зі статистичних функцій.

6. Наведіть приклад статистичної функції, аргументом якої може бути логічний (умовний) вираз.

Вправа 16

Проаналізувати в Excel успішність учнів вашої групи (класу) з інформатики за описом.

1) Запустіть програму Excel. Створіть таблицю зі стовпцями, що мають такі заголовки: А — «Прізвище», В, C, D — поточні оцінки, Е — «Підсумкова». Введіть у таблицю прізвища учнів та поточні оцінки.

2) У стовпці Е за допомогою відповідних функцій обчисліть підсумкові оцінки учнів як середнє арифметичне поточних оцінок, округлене до цілого значення.

3) У довільній комірці під прізвищами за допомогою функції C0UNTIFS(C4ETECnMMH) розрахуйте, скільки учнів мають підсумкові оцінки у 5-8 балів.

4) У довільній комірці під прізвищами розрахуйте загальну кількість поточних оцінок усіх учнів.

5) Збережіть файл з іменем Вправа 16 у відповідній папці. Завершіть роботу за комп’ютером.

Комп'ютерне тестування

Виконайте тестове завдання 16 з автоматичною перевіркою на сайті interactive.ranok.com.ua.

 

Це матеріал з підручника Інформатика 8 клас Бондаренко

 

Категорія: Інформатика

Автор: admin от 7-10-2016, 20:23, Переглядів: 2648